SilverReader system requirements

For the best user experience, SilverReader requires an up-to-date browser. We recommend that you use Google Chrome (download: Chrome) or Firefox (download: Firefox) or Safari on Mac (download: Safari).

Internet Explorer 8+ and Opera are also supported.

Feedback and Knowledge Base